最近有客户在使用OJS系统时,在Issue中上传了整刊PDF,但是却打不开,显示空白,如图:

错误代码提示:
viewer.mjs:1Failed to load module script: Expected a JavaScript-or-Wasm module script but the server responded with a MIME type of "application/octet-stream". Strict MIME type checking is enforced for module scripts per HTML spec.经过分析,是viewer.mjs:1报错,表示浏览器尝试加载一个JavaScript模块(.mjs),但服务器返回的mime类型为application/octet-stream(二进制流),而非规范要求的text/javascript,从而导致浏览器因严格的MIME类型检查而拒绝执行脚本。
找到了问题原因,原来是服务端未能正常解析.mjs文件,误将mjs文件返回成了application/octet-stream格式,考虑到服务端底座是使用的nginx软件,修改下nginx配置,让他将mjs文件正确返回就可以了。
#nginx修改方法
http {
types {
application/javascript js mjs;# .mjs和.js文件使用javascript类型
application/wasm wasm; # WebAssembly文件
}
}最近有同学反应,在使用OJS期刊编审系统时,对已发布的投稿文章,进行Doi提交时,提交失败,出现了503 Service Unavailable的错误,是怎么回事呢?如图:收到该同学的故障修复请求后,丁老师对这个问题进行了研究处理。经过...
有使用OJS期刊投稿管理系统的小伙伴提问,最近在给评审发送邮件通知时,经常会遇到邮件据收被退回的情况,这是怎么回事呢?如图:遇到这种情况,需要先测试OJS的发信功能是否正常,具体可以通过:1.忘记密码,找回密码,发送重置密码邮件方式。2...
open journal system(开放期刊投稿系统)发布文章时,可以绑定crossfef信息,从而每当发布带有DOI的信息时,DOI和元数据都可以自动存入crossref中,具体的设置方法如下:启用Crossref manage ...
引言:OJS(Open Journal Systems)是一个强大的期刊管理系统,为了确保系统的稳定运行和高效性能,服务器硬件配置至关重要。在对期刊的长期运营中,出版社会收到大量的文章和稿件,并且在OJS系统的文章发布流程中,文章投稿、...