有同学反应,在使用宝塔时,突然Mysql和Redis停止运行了,怎么启动也启动不了,Mysql启动失败,并且也不报错,没有错误日志;Redis提示启动成功,但是在宝塔里始终是显示未启动状态,用命令行启动显示success,但再执行service redis status时却提示:Redis is not running, buy pid file is exits /www/server/redis/redis.pid,这是怎么回事呢?如图:

丁老师在接到求助信息后,登录该服务器进行,分别进行了以下排查:
1.卸载redis然后重装,错误问题依旧;
2.安装redis旧版本,错误问题依旧;
3.删除/www/server/redis/redis.pid,然后重启redis,错误依旧;
4.用命令行重启Mysql,提示启动失败,无错误信息,无错误日志;
以上方法都试了个遍,还有说什么vi /etc/init.d/redis,在什么39行前插入rm -rf /www/server/redis/redis.pid && service redis restart && service redis status的,都试了,统统无效。反正在百度查的相关网页没有一个能解决问题的。
正当丁老师百思不得其解时,突然注意到,/www/server/redis/redis.pid和redis.log的文件size为0,咦,好像不对,即使启动失败,这两个文件也不该为0的,至少该写入点什么错误日志吧!为什么为0呢,是没有写入,还是写入不了呢?有问题!绝对有问题!突然灵光一现,df -hl,sh*t!磁盘满了!

查了一堆问题,都没有注意,进入宝塔首页一看,原来是磁盘满了!怪不得,相关程序无法写入日志、无法生成运行缓存、无法启动。
查到问题后,赶快对服务器进行了清理,清理后空出了10多个G空间,重启后redis和mysql就自动启动成功了,为了安全起见,又对linux服务器进行了扩容,这下算是彻底解决这个问题了。
这件事情告诉我们,很多看似复杂的问题,其实是由很简单的原因引起的,在对故障进行排查时,一定不要照本宣科,总认为是技术上的问题,多从底层排查,有时候问题的故障就在你眼前。
最近在使用Edge浏览器DevTools时,忽然发现在调试css时,html中多了一个图标,提示“ask pilot about this elements and its styles”,如图:经过测试,这个功能其实就是点击了以后,浏...
上一期我们讲到了《微信小程序发布后多久可以能被搜索到?》,我们已经知道了微信小程序在上架后,多久能被搜索到的一个时间范围。本期我们讲一下,微信小程序被搜索,如何提升排名,是搜索结果靠前的方法。首先,微信小程序的搜索结果排名,并没有一个固...
Wordpress更新有两种方式,一种是自动更新,一种是手动更新。如何查看Wordpress的当前版本?1.用管理员登录Dashbord,如果Wordpress有新更新,在顶部会自动显示有新版本发布,提示进行更新。2.用管理员账号登录后...
在上一篇文章中,我们介绍了如何在宝塔的网站中设置禁止在指定目录中读取运行php文件(见:《宝塔网站安全增强 - 禁止在指定目录执行PHP等脚本文件》),在本篇中,我们将会介绍如何在包头的网站中设置,禁止蜘蛛、爬虫、黑客扫描探针等恶意程序...
国外很多VPS购买后,只有密码,没有登录账号,如何登录呢?我们以one.com为例,购买了VPS后,只能设置密码,但是用root,也无法登录,是怎么回事呢?查了官方文档,原来修改的VPS密码,不是root的,这个VPS默认的账号是admin...
fontawesome所有图标class类名单,适用于4.7.0版本。总计有593个图标class类(包含别名):fa-500pxfa-address-bookfa-address-book-ofa-address-cardfa-addre...
丁老师软件,推出图片在线加水印功能,支持图片和PDF文件加水印,可以添加文字水印、图片水印,文字水印支持调整文字大小、文字颜色、位置、透明度等,添加水印后可以自动生成文件,可以下载。在线添加图片水印地址https://www.dls6.co...
这几年AI技术的发展已经达到新的高度,从提高个人生产力到企业操作效率的各个方面,AI都扮演着不可或缺的角色。无论是进行语言交流、内容创作、或是任务管理,都有相应的AI工具可以帮助我们更加轻松地完成工作。以下是丁老师觉得不错的AI工具推荐,希...