首页 > 原创文章 > 技术应用 > 查看文章

宝塔面板增加mime类型的方法

所属分类:技术应用 来源: 丁老师原创 更新时间:2026-02-25 09:33 浏览: 1937 IP属地: 深圳

有同学咨询,使用的是宝塔面板,现在需要给网站增加一个Mime类型(如mjs),在宝塔中找了很久也没找到可以设置的地方,请问丁老师这个功能该如何增加呢?今天丁老师分享给大家。

Mime类型,是指网站可以浏览和下载的文件类型,Mime类型的设置一般是在web服务器软件中,如Apache和Nginx。在宝塔面板中没有直接设置Mime类型的地方,需要进入对应web服务器的配置文件中修改参数才可以实现,具体方法如下。

使用Apache的宝塔面板设置Mime类型
方法一:
1.点击左侧菜单“文件”,然后定位到www/server/apache/conf目录。

image.png

2.在该目录中,找到mime.types文件,选中后点击右键,选择“编辑”。

image.png

3.比如我们要增加apk格式,可以在在文件末尾添加一行。

application/vnd.android.package-archive apk

4.保存然后重启Apache。

方法二:
1.点击左侧菜单"网站",然后进入要设置添加Mime类型的网站。
2.在进入网站目录,找到.htaccess文件,右键点击编辑。

image.png

#单个文件格式
AddType application/vnd.android.package-archive .apk

#多个文件格式
AddType application/json .json
AddType application/wasm .wasm

使用Nginx的宝塔面板设置Mime类型
1.点击左侧菜单“文件”,然后定位到www/server/nginx/conf目录。

image.png

2.在该目录中,找到mime.types文件,选中后点击右键,选择“编辑”。

image.png

3.打开文件后,可以增加一行新的Mime类型,也可以在原有的Mime类型上修改。

#修改javascript类型,增加mjs格式
application/javascript                           js mjs;

#增加Apk文件格式类型
application/vnd.android.package-archive          apk

4.修改完成后,点击保存即可,然后在网站中测试是否生效,如果未生效,需要重启nginx。

相关文章

在Mac OS中彻底卸载java的方法

卸载AdoptOpenJDK#在开源包管理器中输入命令 brew uninstall adoptopenjdk8卸载OpenJDK#在开源包管理器中输入命令 brew uninstall openjdk8彻底卸载Java1.删除Java...

Linux彻底卸载删除mysql的方法

一、查看系统安装mysql的情况;rpm -qa | grep -i mysql二、关闭Mysql服务;service mysql stop三、批量删除mysql相关的包;rpm -qa | grep mysql | xargs yum...

Google LiteRT.js是什么?能实...

Google于2026年7月9日发布了LiteRT.js库,是一个用于在JavaScript环境中运行AI模型的工具库,今天丁老师就Google LiteRT.js进行介绍。一、Google LiteRT.js介绍LiteRT.js,读...

宝塔 error while loading...

在宝塔安装PHP时,提示:启动失败: /www/server/php/80/sbin/php-fpm: error while loading shared libraries: libicuio.so.73: cannot open ...

推荐文章

小红书个人账号/认证账号/企业号区别一览

普通账号个人认证号企业认证号蓝色认证标识薯条推广聚光平台效果广告普通应商业合作以KOL/KOC身份和品牌合作以品牌方身份发起起合作开设店铺个人店铺或个体户(不支持港澳台公司申请)旗舰店店或专卖店(支持港澳台公司申请)主动私信每天10位陌生用...

Windows11右键恢复经典模式的方法[亲...

windows11更新后,不管是桌面的右键,还是文件上点右键,都非常地别扭,而且也非常的卡顿。在网上找了一堆方法,都不管用,经过不懈努力,终于找到了真正能恢复经典版右键的方法。废话不多说,具体方法如下:1.以管理员方式运行CMD打开后,在C...

Linux使用lnmp套件安装后打卡默认站点...

最近要在某单位内网部署项目,使用了lnmp来配置环境,软件安装成功,可安装后不管是打开ip地址还是默认站点,都提示nginx 403 forbidden,这是怎么回事呢?首先,已经出现了nginx 403提示,说明nginx是安装正常的。其...

Wordpress如何开启错误调试,查看错误...

在使用wordpress的过程中,有的时候部分页面打不开,或是程序不能正常使用,也没有显示具体的错误信息,这个时候该怎么办呢?首先是查看错误日志,可以查看wordpress本身的错误日志,以及php的错误日志。这时有朋友提问了,wordpr...