OJS中打开PDF特别慢是怎么回事,如何解决

所属专题:OJS期刊管理系统 来源: 丁老师原创 更新时间:2026-10-08 10:03 浏览: 68 IP属地: 深圳
OJS(Open Journal Systems)期刊投稿管理系统

这几天有使用OJS期刊系统(Open Journal Systems)的同学咨询丁老师,他们在OJS系统上发表的文章,在点击PDF在线预览时特别慢,大概要等个十几秒才能打开,这是怎么回事呢?今天丁老师针对这个情况进行一下分析。

问题情况
1.该问题主要是在OJS下打开的文章,点击PDF在线预览后,需要加载大量时间后才能正常显示,根据观察一般在打开10-18秒左右才可以显示。
2.此问题主要是在国内网络访问时出现,在国外网络访问时正常。

问题分析
根据问题情况大致可以分析出,文章的PDF并不是显示不了,而是在显示的过程中,需要消耗很长的时间去加载。并且国外网络没有这个问题,仅仅在使用国内网络时才出现这个情况。由此可以分析出,在打开文章PDF时,系统应该是加载了某些外网的程序或脚本,但是国内网络因为被墙访问不了,所以就出现了十几秒的卡顿和延迟,而国外网络可以访问,所以没有这个情况。

问题排查
通过在打开文章PDF时,对加载程序和脚本的分析,发现在PDF在线浏览时,会加载一个google的api脚本文件。

https://www.google.com/recaptcha/api.js

该脚本文件是谷歌验证码的API接口,如果在OJS的配置中开启了recaptcha,则在加载PDF时就会自动去读这个远程脚本,而众所周知google.com在国内访问不了,所以就会出现卡顿和延迟的情况。

问题解决
1.关闭OJS的google recaptcha,在OJS的config.inc.php文件中,找到[captcha]模块,把recaptcha设置为off,然后重新打开文章的pdf进行测试,观察是否还加载google的recaptcha/api.js,是否还出现卡顿和延迟。

2.如果在关闭recaptcha后问题依然存在,则可能是因为使用了OJS的自定义模板主题,在该模板主题中定义写死了google的recaptcha/api.js,需要去该模板主题的程序代码中,找到

$this->addScript('recaptcha', 'https://www.google.com/recaptcha/api.js',array('baseUrl' => ''));

类似上述代码,并删除即可。

标签:
下一篇:没有了

ojs相关文章

OJS投稿表单点击提交时出现错误提示怎么办?

在使用OJS期刊管理系统的朋友在问,在OJS系统中投稿时,发布文章的最后一步,提交不了文章,出现错误提示,是怎么回事呢?如图:经过丁老师分析,引起这种故障的原因很多,如果只从表面上看,是看不到具体的问题原因的,但是经过丁老师总结归纳,引...

OJS系统支持学术文章查重吗?

经常有使用OJS(Open Journal Systems)期刊管理系统的客户咨询,OJS系统支持文章查重吗?如何实现呢?今天丁老师就这个问题进行一下解答。OJS支持文章查重吗?首先,OJS系统是不支持文章查重的,因为文章查重涉及到海量...

OJS3.5版本用户注册失败的解决方法

有同学咨询,在使用OJS3.5版本的时候注册用户失败,返回HTTP 500错误。这个OJS期刊管理系统据客户反应说是自己在网上摸索着搭建的,是完成搭建没多久,结果不能用,无奈之下最后还是求助丁老师进行解决。现丁老师将该故障的分析及解决方...

OJS系统安装注意事项及建议

OJS是一款优秀的期刊投稿管理系统,目前已经广泛应用于海内外的学术圈。作为新创期刊,如果要安装OJS软件的话,需要注意什么呢?1.确保有一台纯净的服务器。OJS系统对程序和数据库有特定的要求,需要独立的程序运行环境,无法与其他软件兼容,...