OJS当前最新版本为3.5,很多使用OJS3.4.X的同学,在升级时都遇到了或多或少的问题,丁老师几乎每天都收到有关升级失败的咨询。以下是丁老师整理的常见OJS3.4升级3.5的失败问题及处理方法(持续更新中):
Error 1: MariaDB SQL Syntax Incompatibility
ERROR: Upgrade failed: DB: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB
server version for the right syntax to use near '''' at line 1 (Connection: mysql, SQL: alter table `email_templates_default_data` modify `locale`
varchar(28) not null default ''en'')Error 2: Column Rename Conflicts
ERROR: Upgrade failed: DB: SQLSTATE[42S21]: Column already exists: 1060
Duplicate column name 'redirect_context_id'
(Connection: mysql, SQL: alter table `site` rename column `redirect` to `redirect_context_id`)Error 3: Missing Column Dependencies
ERROR: Upgrade failed: DB: SQLSTATE[42S22]: Column not found: 1054
Unknown column 'context' in 'notification_subscription_settings'
(Connection: mysql, SQL: alter table `notification_subscription_settings` rename column `context` to `context_id`)Error 4: Schema Inconsistency
ERROR: Upgrade failed: DB: SQLSTATE[42S22]: Column not found: 1054
Unknown column 'redirect' in 'site'
(Connection: mysql, SQL: alter table `site` modify `redirect` bigint null)Error 5: Schema Inconsistency
ojs upgrade A database error has occurred: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘’‘’ at line 1 (Connection: mysql, SQL: alter table email_templates_default_data modify locale varchar(28) not null default ‘‘en’’)上述问题是,默认值引用不正确,在MariaDB/Mysql上出现的语法错误,导致在创建或修改表列时,Illuminate Database工具集无法正确转义基于字符串的列默认值,从而引起OJS3.5升级失败。是属于官方程序的一个bug。
解决方法:当提供字符串字面量时,转义应该由Laravel处理。
/**
* Format a value so that it can be used in "default" clauses.
*
* @param mixed $value
* @return string
*/
protected function getDefaultValue($value)
{
if ($value instanceof Expression) {
return $this->getValue($value);
}
if ($value instanceof BackedEnum) {
return "'{$value->value}'";
}
return is_bool($value)
? "'".(int) $value."'"
: "'".(string) $value."'";
}Error 6: Table‘journals’already exists
SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘journals’ already exists (Connection: mysql, SQL: create table journals (journal_id bigint not null auto_increment primary key, path varchar(32) not null, seq float(53) not null default ‘0’ comment ‘Used to order lists of journals’, primary_locale varchar(28) not null, enabled smallint not null default ‘1’ comment ‘Controls whether or not the journal is considered "live" and will appear on the website. (Note that disabled journals may still be accessible, but only if the user knows the URL.)’, current_issue_id bigint null) default character set utf8 collate ‘utf8_general_ci’)Error 7: Table‘invitations’already exists
2025-07-02 15:50:28 [pre-install]
2025-07-02 15:50:28 [load: upgrade.xml]
2025-07-02 15:50:28 [version: 3.5.0.0]
2025-07-02 15:50:28 [code: Installer Installer::checkPhpVersion]
2025-07-02 15:50:28 [code: Installer Installer::installDefaultNavigationMenus]
[02-Jul-2025 15:50:28 UTC] WARNING: The NavigationMenu (ContextId: 1, Title: User Navigation Menu, Area: user) will be skipped because the specified area has already a NavigationMenu attached.
[02-Jul-2025 15:50:28 UTC] WARNING: The NavigationMenu (ContextId: 1, Title: Primary Navigation Menu, Area: primary) will be skipped because the specified area has already a NavigationMenu attached.
[02-Jul-2025 15:50:28 UTC] WARNING: The NavigationMenu (ContextId: , Title: User Navigation Menu, Area: user) will be skipped because the specified area has already a NavigationMenu attached.
2025-07-02 15:50:28 [code: Installer Installer::migrateStaticPagesToNavigationMenuItems]
2025-07-02 15:50:28 [migration: PKP\migration\upgrade\v3_4_0\I10249_FixProfileImageDataLoss]
2025-07-02 15:50:28 [migration: PKP\migration\upgrade\v3_4_0\I9627_AddUsageStatsTemporaryTablesIndexes]
2025-07-02 15:50:29 [migration: PKP\migration\upgrade\v3_4_0\I9535_FixEmptyFileStage]
2025-07-02 15:50:29 [migration: PKP\migration\upgrade\v3_4_0\I9830_FixEmptyUserLocales]
2025-07-02 15:50:29 [migration: PKP\migration\upgrade\v3_4_0\I8592_SiteNotificationSubscriptions]
2025-07-02 15:50:29 [migration: APP\migration\upgrade\v3_4_0\I9813_QuickSubmitSubmissionProgressType]
2025-07-02 15:50:29 [migration: APP\migration\upgrade\v3_5_0\I11241_MissingDecisionConstantsUpdate]
2025-07-02 15:50:29 [migration: PKP\migration\upgrade\v3_5_0\PreflightCheckMigration]
2025-07-02 15:50:29 [migration: APP\migration\upgrade\v3_5_0\I8333_AddMissingForeignKeys]
2025-07-02 15:50:33 [migration: APP\migration\upgrade\v3_5_0\I9892_FloatToDecimalColumnTypeUpdate]
2025-07-02 15:50:33 [migration: PKP\migration\upgrade\v3_5_0\I9895_AddAppKeyToConfigFile]
2025-07-02 15:50:33 [migration: PKP\migration\upgrade\v3_5_0\I9678_RemoveScheduledTasksTable]
2025-07-02 15:50:33 [migration: PKP\migration\upgrade\v3_5_0\InstallEmailTemplates]
2025-07-02 15:50:33 [migration: PKP\migration\upgrade\v3_5_0\I9197_MigrateAccessKeys]
2025-07-02 15:50:33 [revert migration: PKP\migration\upgrade\v3_5_0\InstallEmailTemplates]
2025-07-02 15:50:33 [revert migration: PKP\migration\upgrade\v3_5_0\I9678_RemoveScheduledTasksTable]
2025-07-02 15:50:33 [revert migration: PKP\migration\upgrade\v3_5_0\I9895_AddAppKeyToConfigFile]
2025-07-02 15:50:33 [revert migration: APP\migration\upgrade\v3_5_0\I9892_FloatToDecimalColumnTypeUpdate]
2025-07-02 15:50:33 [revert migration: APP\migration\upgrade\v3_5_0\I8333_AddMissingForeignKeys]
2025-07-02 15:50:33 [downgrade for "APP\migration\upgrade\v3_5_0\I8333_AddMissingForeignKeys" unsupported: Downgrade not supported]
ERROR: Upgrade failed: DB: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'invitations' already exists (Connection: mysql, SQL: create table `invitations` (`invitation_id` bigint not null auto_increment primary key, `key_hash` varchar(255) null, `type` varchar(255) not null, `user_id` bigint null, `inviter_id` bigint null, `expiry_date` datetime null, `payload` json null, `status` enum('INITIALIZED', 'PENDING', 'ACCEPTED', 'DECLINED', 'CANCELLED') not null, `email` varchar(255) null comment 'When present, the email address of the invitation recipient; when null, user_id must be set and the email can be fetched from the users table.', `context_id` bigint null, `created_at` timestamp null, `updated_at` timestamp null) default character set utf8mb4 collate 'utf8mb4_unicode_ci')解决方法:
1.备份旧数据库;
2.删除提示已存在的表“如journals、invitations表”;
3.升级;
4.从旧数据库,恢复导入旧表的数据至新表。
总结:
OJS软件版本分支较多,每个版本的迭代,都是很大规模的更新。因为涉及数据关联、插件兼容性等问题,一些OJS版本在升级时可能会遇到一些意想不到的问题,而这些问题往往很难找到正确的处理方法。
丁老师从事专业的OJS期刊软件安装搭建、二次开发、版本升级服务,对OJS系统有着深入的研究,可以解决各种OJS软件的疑难杂症及故障。同时,丁老师提供OJS版本升级服务,需要升级OJS版本的同学,可以联系丁老师咨询。
最近有一个同学,他们出版社使用的是3.3.0.13版本的OJS系统,最近自己在升级到3.5时,出现了错误,并且之前的数据全部丢失了,人都快吓哭了,联系丁老师进行了紧急修复。那么,是什么原因导致了OJS升级失败,如果遇到这种情况,又该怎么...
有同学咨询丁老师,在对OJS期刊系统(Open Journal Systems)的ROR插件(ROR Plugin)进行更新升级时,系统一直卡着不动,无法升级成功,是怎么回事呢?故障分析:经过丁老师查看OJS系统的错误日志发现,在升级R...
近日,有使用OJS期刊系统的客户提出,怎么突然我的ojs系统期刊首页不显示期刊信息了,而且submission article也不显示了,具体是怎么回事呢?需要丁老师协助帮忙。经过丁老师研究发现,其实这是因为客户没有仔细的学习ojs系统...
经常有同学提问,open journal system期刊系统,可以在国产服务器和操作系统上运行吗?比如鲲鹏服务器、麒麟操作系统、统信UOS等国产系统。因为是高校的期刊出版社,软件系统现在都是部署在了国产服务器和操作系统上,不知道OJS...